Pre-requisites


Contents

1. Android IDE

2. Android API Level

3. Android Device & Emulator

4. Gradle Settings

1. Android IDE

Using our SDK is very simple using Android Studio and Eclipse. You can visit their website for further information on how to download, install, and use them. Throughout this documentation, we will use Android Studio as our default IDE.

2. Android API Level

Below is a table of the minimum & maximum Android API Level supported by the recent SDK releases:

Platform Zoom SDK version Min supported API Level Max supported API Level
Android v4.6.21666.0429 21 29
v4.6.15801.0403 21 29

3. Android Device & Emulator

  • OS: Android 5.0 (API Level 21) or later.
  • CPU: armeabi-v7a, x86, armeabi, arm64-v8a, x86_64

4. Android Projet & Gradle Settings:

  • Android Project:
    • Support AndroidX
  • compileSdkVersion: 29+
  • buildToolsVersion: 29+
  • minSdkVersion: 21
  • Required dependencies
implementation 'androidx.multidex:multidex:2.0.0'
implementation 'androidx.recyclerview:recyclerview:1.0.0'
implementation 'androidx.appcompat:appcompat:1.0.0'
implementation 'androidx.constraintlayout:constraintlayout:1.1.3'
implementation 'com.google.android.material:material:1.0.0-rc01'