Pre-requisites


Contents

1. iOS IDE

2. iOS system version

3. iOS Device & Emulator

1. iOS IDE

Using our SDK is very easy using Xcode. You can visit Apple’s website for further information on how to download, install, and use Xcode. Throughout this documentation, we will use Xcode as our default IDE.

2. iOS system version

Below is a table of the minimum & maximum iOS system version supported by the recent SDK releases:

Platform Zoom SDK version Min supported iOS version Max supported iOS version Max supported Xcode version Supported connections
iOS v5.0.24433.0616 iOS 8 iOS 14 12 WiFi, 4G/LTE

3. iOS Device & Emulator

Our SDK & our SDK demo will work and only work on the following environment:

  • Real iOS Device
    • Type: iPhone, iPad, iPod
    • OS: iOS 8+
  • Emulator
    • Type: iPhone, iPad
    • OS: iOS 8+

Note: In our Github repo, we provide two versions of SDK - one will work on both device and emulator, and the other one will only work on the real device. Please visit our Github repo for further information: https://github.com/zoom/zoom-sdk-ios.